icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.qxpfsz.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

新天地娱乐 www.447134.com-家有惊喜福彩三d| www.603261.com-江苏快餐福彩| www.681455.com-福彩带连线的专业版| www.761733.com-有没有时时彩赚钱的| www.877281.com-七乐彩销售截止时间| www.948181.com-排列三众彩网杀码| 天下彩www.754880.com| www.mk05.com-时时彩三星直选遗漏| www.23yp.com-6698彩票违法吗| www.528.tv-澳门快三下载安装| www.6508.net-2019七星彩票| www.22863.cc-湖南中国体彩网| www.68276.cc-今期猛虎报财神彩图| www.506212.com-体彩七位数开奖直播| www.589646.com-体育彩票19095| www.673234.com-中彩双色球开奖结果| www.754400.com-博彩白菜大论坛| www.832082.com-977彩票官方正版| www.913512.com-人人买彩票安全吗| www.sh61.cc-92彩票app-| www.54jo.com-贵州彩民5000万| www.540110.com-7彩票平台-| www.663935.com-头彩网下载-| www.887644.com-彩票代理推广方式| www.957446.com-红牛彩票是真的吗| 大赢家彩票www.354211.com| www.sl25.com-重庆时时彩倍率漏洞| www.48ih.com-利彩客户端下载| www.980671.com-易彩乐软件-| www.pg07.com-玩吉林快三能赢钱不| www.30hw.com-新浪爱彩下载苹果版| www.629.red-彩票直通车能提现么| www.11zv.com-369cc彩票下载| www.3073.cm-七星彩番外| www.12840.com-足球彩票去哪里买| www.mw10.com-安微快三一定牛预测| www.56tv.com-体彩胆拖复式投注表| www.3558.in-糖果派对彩金论坛| www.37818.com-体彩开奖号码怎么查| www.006754.com-福彩直播间下载| www.128035.com-彩虹第一集-| www.240678.com-颖彩双色球专家预测| www.526403.com-新快乐8时时彩| www.609679.com-头奖彩票可靠吗| www.683869.com-推店彩票app下载| www.760603.com-时时彩不定位二码| www.939319.com-快三怎么投注有盈利| www.992308.com-福彩预测双色球| www.by83.com-七星彩票术语大全| www.vw53.com-购彩iv-| www.14vv.com-3d福彩怪字-| www.88wg.com-985彩票平台| www.664804.com-用彩铅画的花草树木| www.755937.com-4567彩票app| www.883166.com-彩678平台怎样| www.974148.com-网易彩票彩种| www.cai6663.com长春快三开奖号| www.qx61.com-金鹰时时彩全天计划| www.02vi.com-彩虹什么意思同性恋| www.736986.com-网上购彩平台哪个好| www.900529.com-怎样买彩票才能中奖| www.971540.com-手机彩票客户端下载| www.cp0114.com-江西多乐彩开奖号码| www.qy23.com-希望手游彩票| www.17zz.com-七乐彩多功能选号器| www.237.me-时时彩2星座号视频| www.3734.vip-彩票管家真实吗| www.9361.wang-百乐城彩票-| www.816329.com-快三平台赌博骗局| www.953894.com-海南彩票-| www.hq88.com-新浪足彩比分直播| www.253176.com-搜神传好彩妹剧照| www.325295.com-彩票假的-| www.2901.me-家彩网独胆预测| www.036769.com-快三拖码全中| www.141117.com-彩99赢几十万| www.434343.com-体彩福彩摇号机下载| www.696772.com-金华体彩电话号码| www.787343.com-新彩票走势网势首页| www.880876.com-黑彩网站有没有漏洞| www.973639.com-3d字谜彩吧-| www.br92.com-信彩三分快三计划| www.v10.in-搞笑彩票中奖信息| www.54yr.com-贵州体彩站怎么申办| www.1195.pw-本港彩票香港六网址| www.22787.com-九州博彩娱乐官网| www.91128.com-好彩蓝莓爆珠好抽吗| www.111796.com-大资本彩票怎么样| www.222692.com-湖北快三专家推荐| www.284997.com-生病彩票-| www.365425.com-彩票搜索引擎一彩搜| www.466947.com-福彩几个中奖| www.551616.com-足彩网首页-| www.673898.com-古建彩绘纹样图片| www.761462.com-好彩自然来什么意思| www.828892.com-九彩彩票官网首页| www.892578.com-彩票软件哪个最可靠| www.954513.com-cb8彩宝彩票| 全民彩票www.qm72.com| www.587967.com-佳能彩色复印机a3| www.678781.com-时时彩开奖结果| www.763175.com-下载富贵彩票| www.832324.com-7彩娱乐-| www.894759.com-彩票试机号查询全国| www.956975.com-hk百彩-| 818合彩www.www.9889hc.com| www.bb15.com-五分彩怎么稳赚不亏| www.qs53.com-福彩是几位数| www.26df.com-福彩图迷字迷总汇| www.070271.com-彩678赚钱吗| www.87jl.com-体彩怎么注册| www.679592.com-问题彩民戒賭| www.963251.com-彩钢板多少钱一平米| www.om1.com-手机app彩票停售| www.uc22.cc-江苏快三技巧与方法| www.902727.com-彩票平台代理找谁做| www.967646.com-百合娱乐玛雅彩票| 95彩票www.767387.com| www.so60.com-时时彩的和值表| www.07vw.com-彩铅色彩如何配色| www.81ki.com-彩票支票怎么兑现金| www.1233.cc-云南快乐彩十分电脑| www.5503.com-彩虹岛外挂-| www.82813.cc-6188彩票网-| www.135717.com-彩票店打票员工资| www.205531.com-喜乐彩票合法吗| www.284344.com-赢彩彩票官方| www.373393.com-鼎盛国际彩票| www.592484.com-彩票中奖记录| www.663021.com-彩票黑蝴蝶-| www.36439.com-澳博彩票合法吗| www.314465.com-博彩怎么刷流水赚钱| www.393516.com-咸阳体彩店-| www.510551.com-体育彩票几天一期| www.583751.com-中国官方彩北京赛车| www.647767.com-陶宝买彩票-| www.772275.com-竞彩提成-| www.832668.com-七彩娱乐平台总代| www.884502.com-澳洲时时彩开奖号码| www.947974.com-四川体育彩票| www.988870.cc-2628彩票下载| www.mt1.com-人人中彩票升级维护| www.np74.com-宁夏福彩中心| www.1gz.com-老版乐彩论坛| www.366661.com-用彩铅画的凤九| www.461200.com-彩宝网试机号今天| www.531974.com-临沂福利彩票中奖| www.1122.space-竞彩足球比赛中断| www.466365.com-七乐彩特别号怎么选| www.405918.com-巨丰彩票50705| www.203131.com-福彩3d开奖走式图| www.321058.com-掌中彩福利彩票| www.98137.com-分分快三万能码| www.419395.com-机打彩票设备| www.513666.cc-快三两码-| www.585953.com-现金彩票靠谱吗| www.656200.com-足彩分析预测方法| www.578048.com-太湖钓君福彩三字迷| www.638968.com-乐和彩双色球走势图| www.697625.com-福彩中心清明放假吗| www.754474.com-双彩在哪下载| www.805058.com-彩票了3d怎么选号| www.860275.com-彩37官网下载| www.902685.com-快三一直买豹子赚钱|